نصب php 5.6 در Centos/RHEL نسخه ۶x و ۷x با استفاده از yum

ایجاد شده توسط | آبان ۲۳, ۱۳۹۵

PHP نسخه ۵٫۶٫۲۷ در اکتبر ۲۰۱۶ معرفی شد که میتوان ان را با استفاده از yum نصب کرد. این نسخه از PHP همانند دیگر ورژن های PHP در Centos نسخه ۶x و در Redhat نسخه ۷x پشتیبانی و قابل استفاده میباشد. در سیستم عامل های Centos 6X و redhat 6X نسخه پیشفرض PHP 5.3 میباشد و همانطور که میدانید جهت نصب و یا استفاده بسیاری از اسکریپت ها و CMS ها نیاز است تا نسخه PHP بروز رسانی شود.

wikiconfig-php upgradeتا به امروز نسخه ۷ برای PHP عرضه شده است که معمولا نسخه PHP با توجه به سازگاری اسکریپ یا WAP مورد نظر انتخاب میشود. قبل استفاده از دستورات بطور کامل این مقاله را مطالعه نمایید.

بطور خلاصه امکانات زیر به php 5.6.23 اضافه شده است:

  • constant scalar expressions
  • variadic functions
  • argument unpacking
  • پشتیبانی از اپلود بیش از ۲ گیگابایت فایل
  • اضافه شدن یک دستور جدید به نام phpdbg برای دیباگ کردن
  • ارتقا SSL/TLS

جهت مشاهده دیگر تغییرات و نحوه Migrate کرد لینک Migrating from PHP 5.5.x to PHP 5.6.x را مطالعه نمایید.

نصب/ ارتقا PHP

در ابتدا باید برسی نمایید که ایا PHP در سرور نصب میباشد یا خیر که در هر صورت باید بطور کامل با تمامی افزونه های نصب شده حذف شود به این دلیل که ممکن است زمان نصب ورژن جدید پیغام خطای conflict بین دو نسخه از ابزار های جدید و ابزار های قدیمی نصب شده را دریافت نمایید. جهت حذف کامل دستورات زیر در محیط ssh وارد نمایید:

پس از حذف کامل PHP جهت نصب نسخه جدید باید مخزن های نرم افزاری yum را اپدیت نمایید. برای این منظور دستورات زیر را وارد نمایید:

CentOS/RHEL 7.x :

CentOS/RHEL 6.x :

حالا میتوانید PHP نسخه ۵٫۶ را به همراه افزونه های ان نصب نمایید. برای  PHP را به همراه Opcode cache یا بدون ان نصب نمایید:

یا در صورت نیاز میتوانید PHP-FPM را به همراه Opcode cache نصب نمایید:

آپگرید

بهتر است جهت اپگرید نسخه PHP نرم افزار های موجود در سیستم را برسی نمایید تا مطمئن شوید از نسخه جدید پشتیبانی میکند. بهتر است بدون اگاهی اقدام به اپگرید ننمایید یا از یک متخصص مشورت بگیرید. میتوانید از یک سرور Fresh استفاده نمایید و نسخه جدید را نصب نموده سپس WAP ها و اسکریپت های خود را جهت برسی سازگاری در سرور Fresh اجرا کنید تا در سرویس دهی فعلی شما اختلالی ایجاد نشود.

در سرور عملیاتی جهت اپگرید میتوانید از دستورات زیر استفاده نمایید:

پکیج های قابل نصب

 با استفاده از دستور yum میتوانید برخی دیگر از Package های فعال مورد نیاز مانند PDO و اتصال دهنده mysql را نصب نمایید که در جدول زیر بصورت Cheat sheet لیست شده است.

Package Provides
php56w mod_php, php56w-zts
php56w-bcmath
php56w-cli php-cgi, php-pcntl, php-readline
php56w-common php-api, php-bz2, php-calendar, php-ctype, php-curl, php-date, php-ereg, php-exif, php-fileinfo, php-filter, php-ftp, php-gettext, php-gmp, php-hash, php-iconv, php-json, php-libxml, php-openssl, php-pcre, php-pecl-Fileinfo, php-pecl-phar, php-pecl-zip, php-reflection, php-session, php-shmop, php-simplexml, php-sockets, php-spl, php-tokenizer, php-zend-abi, php-zip, php-zlib
php56w-dba
php56w-devel
php56w-embedded php-embedded-devel
php56w-fpm
php56w-gd
php56w-mysql php-mysqli, php_database
php56w-pdo php56w-pdo_sqlite, php56w-sqlite3
php56w-pecl-geoip
php56w-pecl-memcache
php56w-soap
php56w-xml php-dom, php-domxml, php-wddx, php-xsl

برای مثال میتوانید برای نصب php-common یا افزونه ارتباط mysql از دستورات زیر استفاده نمایید:

جهت اعمال تغییرات در سرور، اپاچی را ریستارت نمایید.


موفق و پیروز باشید.

منبع “WikiConfig

پاسخ دهید

نشانی ایمیل شما منتشر نخواهد شد. بخش‌های موردنیاز علامت‌گذاری شده‌اند *